autoload.php

Location: /application/config/autoload.php

As of Community Auth version 3.2.0 (March 4, 2017), there is no longer any requirement to modify the autoload.php file. Over time the burden of using the autoload.php file turned out to be too great, and Community Auth’s dependencies are now loaded in Auth_Controller.php.

You may have never considered autoloading through autoload.php to be a burden, but if you ever need to run a cron job or run something through CLI, you’d quickly realize the problem. Autoloaded classes would cause problems, and as a quick fix you could wrap your autoloading in a check for ! is_cli(), but this kind of thing is simply not desirable.

Removing the autoloading requirement also makes installation one step shorter, so enjoy!